"This page is taking way too long to load"
Incident Report for CS50
Resolved
This incident has been resolved.
Posted 2 months ago. Aug 31, 2018 - 08:27 EDT
Identified
GitHub (on which CS50.me depends) seems to be having issues at the moment, the result of which is "This page is taking way too long to load" (and possibly a unicorn). CS50.me should start working again as soon as GitHub is too!
Posted 2 months ago. Aug 31, 2018 - 00:44 EDT
This incident affected: cs50.me.