Some CS50 Certificates still unavailable
Incident Report for CS50
Resolved
This incident has been resolved.
Posted Sep 09, 2020 - 01:46 EDT
Identified
Apologies, upgrading the server, just taking a bit of time!
Posted Sep 08, 2020 - 17:58 EDT
This incident affected: certificates.cs50.io.