check50 and submit50 are down
Incident Report for CS50
Resolved
This incident has been resolved.
Posted about 2 months ago. Jul 26, 2019 - 16:50 EDT
Monitoring
A fix has been implemented and we are monitoring the results. Let sysadmins@cs50.harvard.edu if you're still facing any issues!
Posted about 2 months ago. Jul 26, 2019 - 15:38 EDT
Identified
We are deploying some changes to check50 and submit50. If you're having trouble using check50 or submit50 in the CS50 IDE, you may run:

sudo pip3 install --upgrade check50 submit50

If you're using CS50 Sandbox or CS50 Lab, you may run:

pip3 install --upgrade check50 submit50

for now to upgrade the versions of both tools. These versions will eventually be upgraded automatically too once the deployment is complete. Let sysadmins@cs50.harvard.edu know if you need further help!
Posted about 2 months ago. Jul 26, 2019 - 12:51 EDT
This incident affected: check50 and submit50.