GitHub Codespaces Unavailable for Some Users

Incident Report for CS50

Resolved

This incident has been resolved.
Posted Jul 20, 2026 - 09:34 EDT

Investigating

We’ve received reports from some users that their Codespaces are currently inaccessible. As Codespaces are managed by GitHub, we do not have further visibility into the issue at this time.

Please check GitHub’s status page for updates at githubstatus.com and try accessing your Codespace again later.

You can also try visiting https://cs50.dev/codespaces to create a new Codespace by clicking the "Create codespace on main" button.
Posted Jul 04, 2026 - 12:45 EDT
This incident affected: cs50.dev.