New users might not be able to join courses

Incident Report for CS50

Resolved

This incident has been resolved.
Posted Feb 24, 2023 - 19:29 EST

Identified

Afraid this issue is likely to persist through the weekend, but we've reached out to GitHub. (The errors are API-related.) In the meantime, if you're new to CS50, you're welcome to work on the course's problem sets, but know that you might not be able to join submit.cs50.io yet, so you might not be able to use check50 or submit50 yet either. But those shouldn't stop you from working on code itself!
Posted Feb 24, 2023 - 16:22 EST

Investigating

We are currently investigating this issue.
Posted Feb 24, 2023 - 07:38 EST
This incident affected: check50, submit.cs50.io, and submit50.