GitHub has deployed a mitigation that should improve the GitHub API token issues. We have also pushed an update to CS50 Codespace to accommodate these changes. Please update your Codespace immediately when prompted, or run update50 in your Codespace.
We've learned that this issue involves GitHub components that are beyond our control. In affected cases, the GitHub account would have encountered the rate limit regardless of how the Codespace was accessed.
As a workaround, you can configure GitHub SSH, which should allow tools such as submit50 and check50 to work:
CS50 Duck inside Codespaces may also be affected by this issue. In the meantime, https://cs50.ai remains operational.
Posted Aug 22, 2026 - 08:23 EDT
Update
We have been working with GitHub to address the issue, but for the moment, if you are experiencing GitHub token issues (either an invalid token or your GitHub account being rate-limited), please do the following:
1. If your Codespace prompts you to update, please run update50 to update your Codespace immediately. 2. If you are unable to access your Codespace because your GitHub account is being rate-limited, please close all Codespace browser windows and tabs and stop interacting with github.com in any way. Wait one hour, then visit https://cs50.dev to access your Codespace. 3. If you are already running the latest version of CS50 Codespace but are still experiencing a GitHub token issue, please take a screenshot of the error message and email it to sysadmins@cs50.harvard.edu, along with your GitHub username and the content of https://cs50.dev/debug
If your Codespace is up to date and your GitHub account is not rate-limited, yet the token issue still persists, please do the following:
1. If your Codespace prompts you to update, please do so immediately. 2. If you are unable to access your Codespace, please close all Codespace browser windows and tabs, wait one hour, then visit https://cs50.dev and update your Codespace. 3. If you are already running the latest version of CS50 Codespace but are still experiencing a GitHub token issue, please take a screenshot of the error message and email it to sysadmins@cs50.harvard.edu, along with your GitHub username.
Posted Aug 21, 2026 - 12:32 EDT
Identified
We have identified the issue and are currently working on a fix.