CS50 Lab, CS50 Sandbox not working as expected
Incident Report for CS50
Resolved
If you have an existing lab or sandbox exhibiting these systems (because they were created during the malfunction), do just run

curl -s https://gist.githubusercontent.com/dmalan/65a92cd701b1dd8ee4d8f07414e4bb07/raw/f98809205e694d3ef9fae101cb989ab1d5c95fb7/cs50.sh | bash

in a terminal window, then open and use a new one (via the + icon)!
Posted about 1 month ago. Feb 19, 2019 - 00:11 EST
Identified
Afraid CS50 Lab and CS50 Sandbox are currently missing some configuration files, the result of which might be that terminal windows' prompts (i.e., shells) might look a bit different than expected. And commands like `make` and `python` might not behave as expected. We've rolled out a temporary fix, and a permanent fix should be rolled out soon. In the meantime, you can run

curl -s https://gist.githubusercontent.com/dmalan/65a92cd701b1dd8ee4d8f07414e4bb07/raw/f98809205e694d3ef9fae101cb989ab1d5c95fb7/cs50.sh | bash

in a terminal window to fix existing labs and sandboxes manually. Note that you'll then need to open (via the + icon) and use a new terminal window to see the new settings, rather than continue using any already-open terminal windows.

Sorry for the trouble!
Posted about 1 month ago. Feb 19, 2019 - 00:00 EST
This incident affected: lab.cs50.io and sandbox.cs50.io.