CSS, JavaScript not working on cs50.harvard.edu
Incident Report for CS50
Resolved
This incident has been resolved.
Posted Dec 29, 2019 - 13:58 EST
Investigating
Apologies, sites living at cs50.harvard.edu should be back to normal shortly!
Posted Dec 29, 2019 - 12:54 EST
This incident affected: cs50.harvard.edu.