CS50 Video Player down
Incident Report for CS50
Resolved
This incident has been resolved.
Posted Sep 15, 2021 - 17:34 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 15, 2021 - 17:28 EDT
Identified
Should be back up shortly, apologies!
Posted Sep 15, 2021 - 17:25 EDT
This incident affected: video.cs50.io.