Incident with GitHub Codespaces

Incident Report for CS50

Resolved

This incident has been resolved.
Posted Oct 06, 2025 - 12:50 EDT

Monitoring

GitHub has completed a regional failover to West Europe, which should resolve the issue affecting our service.

If you are using GitHub Codespaces, please restart your codespace by visiting https://cs50.dev/restart.
Posted Oct 06, 2025 - 09:43 EDT

Investigating

We have received multiple reports indicating that there are issues with GitHub Codespaces. Some users in the Europe region are impacted, but we don’t have further information at this point.

Please check githubstatus.com for more information.
Posted Oct 05, 2025 - 16:59 EDT
This incident affected: cs50.dev.