CS50 ID offline
Incident Report for CS50
Resolved
CS50 ID (and, in turn, CS50 IDE and other apps) should now be back online. Apologies!
Posted 6 months ago. Nov 29, 2018 - 18:48 EST
Update
We are continuing to work on a fix for this issue.
Posted 6 months ago. Nov 29, 2018 - 18:38 EST
Identified
CS50's authentication service, aka CS50 ID, is currently offline but will be back up shortly!
Posted 6 months ago. Nov 29, 2018 - 18:37 EST
This incident affected: forms.cs50.io, id.cs50.net, legacy.cs50.io, and vault.cs50.io.