Did you recently lose files or find some corrupted?
Incident Report for CS50
Resolved
This incident has been resolved.
Posted about 1 month ago. Nov 14, 2017 - 13:21 EST
Update
A fix has been implemented and we are monitoring the results.
Posted about 2 months ago. Oct 23, 2017 - 10:05 EDT
Monitoring
Some issues have been identified by Cloud9 and some fixes were implemented. Please let sysadmins@cs50.harvard.edu know if you are still losing files or having them corrupted. Please include your CS50 IDE username and workspace name (which should be part of the workspace URL), a list of the affected files, and in case of missing files:
* any (estimated) timestamps of when the files were last modified and or missed.

in case of corrupted files:
* any (estimated) timestamps before or after the files were corrupted.
* any events you believe might have lead to the corruption.

Thank you!
Posted 2 months ago. Oct 11, 2017 - 17:50 EDT
Investigating
We have been getting reports about corrupted or lost files in some workspaces. We have reported the problem to Cloud9 and they have been investigating. We will follow up as soon as possible.

In the mean time, if some files are corrupted or lost in your workspace, let sysadmins@cs50.harvard.edu know your CS50 IDE username and workspace name which should be part of the workspace URL, along with the paths for the files in question.
Posted 2 months ago. Oct 09, 2017 - 15:10 EDT
This incident affected: cs50.io.