Having trouble with check50?
Incident Report for CS50
Resolved
This incident has been resolved.
Posted 23 days ago. Oct 30, 2017 - 02:01 EDT
Identified
Apologies, should be fixed shortly this eve!
Posted 23 days ago. Oct 30, 2017 - 01:50 EDT
This incident affected: check50.