missing field 'prompt' initializer
Incident Report for CS50
Resolved
Please run update50 for a permanent fix!
Posted about 1 month ago. Jul 15, 2017 - 11:57 EDT
Identified
If currently seeing this error when compiling a program on CS50 IDE, stand by for a permanent fix! In the meantime, if using a Makefile, you can add

-Wno-missing-field-initializers

to your Makefile's definition of CFLAGS and then re-run make. If not using a Makefile, you can run

export CFLAGS="$CFLAGS -Wno-missing-field-initializers"

and then re-run make.
Posted about 1 month ago. Jul 15, 2017 - 07:25 EDT