Seeing HTTP 503 or HTTPS error?
Incident Report for CS50
Resolved
This incident has been resolved.
Posted 30 days ago. Oct 23, 2017 - 11:30 EDT
Update
A fix has been implemented and we are monitoring the results.
Posted 30 days ago. Oct 23, 2017 - 10:00 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 30 days ago. Oct 23, 2017 - 09:49 EDT
Update
The issue has been identified and a fix is being implemented.
Posted 30 days ago. Oct 23, 2017 - 09:37 EDT
Identified
If seeing an HTTP 503 or HTTPS error with cs50.net, cs50.harvard.edu, or cs50.yale.edu, apologies! Minor DNS issue. 0:-) Should be fixed shortly.
Posted 30 days ago. Oct 23, 2017 - 09:37 EDT
This incident affected: cs50.harvard.edu and cs50.yale.edu.