Having trouble with check50, submit50, or CS50.me?
Incident Report for CS50
Resolved
This incident has been resolved.
Posted about 1 month ago. Oct 14, 2017 - 15:58 EDT
Update
The issue has been identified and a fix is being implemented.
Posted about 1 month ago. Oct 14, 2017 - 15:50 EDT
Identified
Looks like a server in the cloud died. We're starting up a new one!
Posted about 1 month ago. Oct 14, 2017 - 15:46 EDT